【严重漏洞通告】Linux系统PPPD远程代码执行漏洞(CVE-2020-8597 )

浏览 : 发布 :2020-03-10

一、      漏洞情况

美国CERT/CC36日发布一则安全公告,提醒用户一个新发现的但已有17年之久的危险远程代码执行漏洞,影响几乎所有基于Linux操作系统以及网络设备固件。该漏洞编号为CVE-2020-8597CVSS评分为9.8,漏洞影响范围广泛,危害较大。此漏洞是pppd中的eap.ceap_requesteap_response函数中rhostname参数存在缓冲区溢出,未经身份验证的攻击者发送恶意伪造的EAP包,可在受影响的系统中远程执行任意代码。影响的判定是基于pppd版本,覆盖centosdebianUbuntulinux系统和使用pppd软件扩展的设备应用均受影响。

二、      漏洞等级

严重

三、      漏洞影响范围

2.4.2 =< pppd =< 2.4.8

受影响的应用、设备与系统,包括:

· Debian

· Ubuntu

· SUSE Linux

· Fedora

· NetBSD

· Red Hat 企业级Linux

· Cisco CallManager

· TP-LINK产品

· OpenWRT嵌入式系统

· Synology (DiskStation Manager, VisualStation, Router Manager)

四、      漏洞修复建议

注意:安装补丁和加固前务必做好备份工作,切记!

安装补丁

目前pppd官方与部分Linux系统已针对受支持的产品发布了修复该漏洞的安全补丁。建议用户及时确认是否受到漏洞影响,尽快采取修补措施。具体措施如下:

1pppd

修复版本:8d7970b8f3db727fe798b65f3377fe6787575426

https://github.com/paulusmack/ppp/commit/8d7970b8f3db727fe798b65f3377fe6787575426

2Centos

修复版本:ppp 2.4.5-34

https://centos.pkgs.org/7/centos-updates-x86_64/ppp-2.4.5-34.el7_7.x86_64.rpm.html

3Ubuntu 12.04 ESM (Precise Pangolin):

修复版本:released (2.4.5-5ubuntu1.3)

https://people.canonical.com/~ubuntu-security/cve/2020/CVE-2020-8597.html

4Ubuntu 14.04 ESM (Trusty Tahr):

修复版本:released (2.4.5-5.1ubuntu2.3+esm1)

https://people.canonical.com/~ubuntu-security/cve/2020/CVE-2020-8597.html

5Ubuntu 16.04 LTS (Xenial Xerus):

修复版本:released (2.4.7-1+2ubuntu1.16.04.2)

https://people.canonical.com/~ubuntu-security/cve/2020/CVE-2020-8597.html

6Ubuntu 18.04 LTS (Bionic Beaver):

修复版本:released (2.4.7-2+2ubuntu1.2)

https://people.canonical.com/~ubuntu-security/cve/2020/CVE-2020-8597.html

7Ubuntu 19.10 (Eoan Ermine):

修复版本:released (2.4.7-2+4.1ubuntu4.1)

https://people.canonical.com/~ubuntu-security/cve/2020/CVE-2020-8597.html

8Ubuntu 20.04 (Focal Fossa):

修复版本:released (2.4.7-2+4.1ubuntu5)

https://people.canonical.com/~ubuntu-security/cve/2020/CVE-2020-8597.html

9debian 8

修复版本:ppp 2.4.6-3.1+deb8u1

https://security-tracker.debian.org/tracker/source-package/ppp

10debian 9

修复版本:ppp 2.4.7-1+4+deb9u1

https://www.debian.org/security/2020/dsa-4632

11debian 10

修复版本:ppp 2.4.7-2+4.1+deb10u1

https://www.debian.org/security/2020/dsa-4632

注:建议使用yumapt等软件包管理工具进行安装。